打印

WAS 8.5在AIX上无法启动图形化概要管理工具WCT或PMT之解

WAS 8.5在AIX上无法启动图形化概要管理工具WCT或PMT之解

WAS 8.5在AIX上无法启动图形化概要管理工具WCT或PMT之解

问题描述:WAS 8.5在AIX上因缺少相应的组件包,而无法启动图形化概要管理工具WCT或PMT
错误信息:在执行 $WAS_HOME/bin/ProfileManagement/ 目录下的 wct.sh 或 pmt.sh 时,报如下错误:
java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
        /.ibm/WebSphere/AppServer/configurations/WCT85/org.eclipse.osgi/bundles/51/1/.cp/libswt-pi-gtk-3659.a (A file or directory in the path name does not exist.)
        swt-pi-gtk (Not found in java.library.path)
        /tmp/swtlib-64/libswt-pi-gtk-3659.a (A file or directory in the path name does not exist.)
        /tmp/swtlib-64/libswt-pi-gtk.a (A file or directory in the path name does not exist.)
        at org.eclipse.swt.internal.Library.loadLibrary(Library.java:267)
        at org.eclipse.swt.internal.Library.loadLibrary(Library.java:174)
        at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:22)
        at java.lang.J9VMInternals.initializeImpl(Native Method)
        at java.lang.J9VMInternals.initialize(J9VMInternals.java:228)
        at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
        at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
        at org.eclipse.swt.widgets.Display.<clinit>(Display.java:132)
        at java.lang.J9VMInternals.initializeImpl(Native Method)
        at java.lang.J9VMInternals.initialize(J9VMInternals.java:228)
        at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:687)
        at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
        at com.ibm.ws.pmt.tools.WasToolApplication.run(WasToolApplication.java:190)
        at com.ibm.ws.pmt.views.standalone.StandAloneToolApplication.run(StandAloneToolApplication.java:70)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
        at java.lang.reflect.Method.invoke(Method.java:611)
        at org.eclipse.equinox.internal.app.EclipseAppContainer.callMethodWithException(EclipseAppContainer.java:587)
        at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:198)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
        at java.lang.reflect.Method.invoke(Method.java:611)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1408)
        at org.eclipse.equinox.launcher.Main.main(Main.java:1384)

执行ldd验证所需要的类库是否存在
ldd /.ibm/WebSphere/AppServer/configurations/WCT85/org.eclipse.osgi/bundles/55/1/.cp/libswt-pi-gtk-3659.a

/.ibm/WebSphere/AppServer/configurations/WCT85/org.eclipse.osgi/bundles/55/1/.cp/libswt-pi-gtk-3659.a needs:
Cannot find libgdk-x11-2.0.a(libgdk-x11-2.0.so.0)
Cannot find libglib-2.0.a(libglib-2.0.so.0)
Cannot find libgtk-x11-2.0.a(libgtk-x11-2.0.so.0)
         /usr/lib/libc.a(shr_64.o)
Cannot find libgobject-2.0.a(libgobject-2.0.so.0)
Cannot find libpango-1.0.a(libpango-1.0.so.0)
Cannot find libgdk_pixbuf-2.0.a(libgdk_pixbuf-2.0.so.0)
Cannot find libgthread-2.0.a(libgthread-2.0.so.0)
         /usr/X11R6/lib/libX11.a(shr_64.o)
         /usr/X11R6/lib/libXtst.a(shr_64.o)
         /unix
         /usr/lib/libcrypt.a(shr_64.o)
         /usr/lib/libiconv.a(shr4_64.o)
         /usr/lib/libIM.a(shr_64.o)
         /usr/lib/libpthreads.a(shr_xpg5_64.o)
         /usr/X11R6/lib/libXext.a(shr_64.o)
         /usr/lib/libgaimisc.a(shr_64.o)
         /usr/lib/libgair4.a(shr_64.o)
         /usr/lib/libodm.a(shr_64.o)

问题所在:于是,可以明确知道是缺少类包导致的。

通过rpm查看相关安装类包情况
rpm -qa
cdrecord-1.9-7
mkisofs-1.13-4
AIX-rpm-6.1.6.0-1
tcl-8.4.7-3
tk-8.4.7-3
expect-5.42.1-3
wget-1.9.1-1

少了不少相关所需要的组件包,下载之
ftp://public.dhe.ibm.com/aix/fre ... .3-2.aix5.2.ppc.rpm
ftp://public.dhe.ibm.com/aix/fre ... .8-1.aix5.2.ppc.rpm
ftp://public.dhe.ibm.com/aix/fre ... .1-1.aix5.2.ppc.rpm
ftp://public.dhe.ibm.com/aix/fre ... .2-1.aix5.2.ppc.rpm
ftp://public.dhe.ibm.com/aix/fre ... .9-1.aix5.2.ppc.rpm
ftp://public.dhe.ibm.com/aix/fre ... 40-6.aix5.1.ppc.rpm
ftp://public.dhe.ibm.com/aix/fre ... .4-2.aix5.2.ppc.rpm
ftp://public.dhe.ibm.com/aix/fre ... .6-4.aix5.2.ppc.rpm
ftp://public.dhe.ibm.com/aix/fre ... 6b-6.aix5.1.ppc.rpm
ftp://public.dhe.ibm.com/aix/fre ... 32-2.aix5.2.ppc.rpm
ftp://public.dhe.ibm.com/aix/fre ... .2-1.aix5.2.ppc.rpm
ftp://public.dhe.ibm.com/aix/fre ... .5-4.aix5.2.ppc.rpm
ftp://public.dhe.ibm.com/aix/fre ... .7-3.aix5.2.ppc.rpm
ftp://public.dhe.ibm.com/aix/fre ... .6-5.aix5.1.ppc.rpm
ftp://public.dhe.ibm.com/aix/fre ... .1-3.aix5.2.ppc.rpm
ftp://public.dhe.ibm.com/aix/fre ... .3-3.aix5.1.ppc.rpm
ftp://public.dhe.ibm.com/aix/fre ... .0-3.aix5.2.ppc.rpm

安装执行顺序
由于各个类有相关的依赖顺序,安装如果有发生错误error: failed dependencies:,则采用如下的安装顺序即可。
rpm -ivh expat-2.0.1-1.aix5.2.ppc.rpm
rpm -ivh zlib-1.2.3-3.aix5.1.ppc.rpm
rpm -ivh freetype2-2.3.9-1.aix5.2.ppc.rpm
rpm -ivh fontconfig-2.4.2-1.aix5.2.ppc.rpm
rpm -ivh gettext-0.10.40-6.aix5.1.ppc.rpm
rpm -ivh glib2-2.12.4-2.aix5.2.ppc.rpm
rpm -ivh libjpeg-6b-6.aix5.1.ppc.rpm
rpm -ivh libpng-1.2.32-2.aix5.2.ppc.rpm
rpm -ivh libtiff-3.8.2-1.aix5.2.ppc.rpm
rpm -ivh xcursor-1.1.7-3.aix5.2.ppc.rpm
rpm -ivh xft-2.1.6-5.aix5.1.ppc.rpm
rpm -ivh xrender-0.9.1-3.aix5.2.ppc.rpm
rpm -ivh pixman-0.12.0-3.aix5.2.ppc.rpm
rpm -ivh cairo-1.8.8-1.aix5.2.ppc.rpm
rpm -ivh pango-1.14.5-4.aix5.2.ppc.rpm
rpm -ivh atk-1.12.3-2.aix5.2.ppc.rpm
rpm -ivh gtk2-2.10.6-4.aix5.2.ppc.rpm

再rpm确认安装的情况
rpm -qa
cdrecord-1.9-7
mkisofs-1.13-4
AIX-rpm-6.1.6.0-1
tcl-8.4.7-3
tk-8.4.7-3
expect-5.42.1-3
wget-1.9.1-1
expat-2.0.1-1
zlib-1.2.3-3
freetype2-2.3.9-1
fontconfig-2.4.2-1
gettext-0.10.40-6
glib2-2.12.4-2
libjpeg-6b-6
libpng-1.2.32-2
libtiff-3.8.2-1
xcursor-1.1.7-3
xft-2.1.6-5
xrender-0.9.1-3
pixman-0.12.0-3
cairo-1.8.8-1
pango-1.14.5-4
atk-1.12.3-2
gtk2-2.10.6-4

安装后再验证所需要的包存在的情况
ldd /.ibm/WebSphere/AppServer/configurations/WCT85/org.eclipse.osgi/bundles/55/1/.cp/libswt-pi-gtk-3659.a
/.ibm/WebSphere/AppServer/configurations/WCT85/org.eclipse.osgi/bundles/55/1/.cp/libswt-pi-gtk-3659.a needs:
         /opt/freeware/lib/libgdk-x11-2.0.a(libgdk-x11-2.0.so.0)
         /opt/freeware/lib/libglib-2.0.a(libglib-2.0.so.0)
         /opt/freeware/lib/libgtk-x11-2.0.a(libgtk-x11-2.0.so.0)
         /usr/lib/libc.a(shr_64.o)
         /opt/freeware/lib/libgobject-2.0.a(libgobject-2.0.so.0)
         /opt/freeware/lib/libpango-1.0.a(libpango-1.0.so.0)
         /opt/freeware/lib/libgdk_pixbuf-2.0.a(libgdk_pixbuf-2.0.so.0)
         /opt/freeware/lib/libgthread-2.0.a(libgthread-2.0.so.0)
         /usr/X11R6/lib/libX11.a(shr_64.o)
         /usr/X11R6/lib/libXtst.a(shr_64.o)
         /opt/freeware/lib/libXrender.a(libXrender.so.0)
         /usr/X11R6/lib/libXext.a(shr.o)
         /usr/X11R6/lib/libX11.a(shr4.o)
         /opt/freeware/lib/libpangocairo-1.0.a(libpangocairo-1.0.so.0)
         /opt/freeware/lib/libcairo.a(libcairo.so.2)
         /opt/freeware/lib/libintl.a(libintl.so.1)
         /opt/freeware/lib/libfontconfig.a(libfontconfig.so.1)
         /usr/lib/libc.a(shr.o)
         /usr/lib/libiconv.a(shr4.o)
         /opt/freeware/lib/libgmodule-2.0.a(libgmodule-2.0.so.0)
         /opt/freeware/lib/libatk-1.0.a(libatk-1.0.so.0)
         /unix
         /usr/lib/libcrypt.a(shr_64.o)
         /usr/lib/libpthreads.a(shr_xpg5.o)
         /usr/lib/libiconv.a(shr4_64.o)
         /usr/lib/libIM.a(shr_64.o)
         /usr/lib/libpthreads.a(shr_xpg5_64.o)
         /usr/X11R6/lib/libXext.a(shr_64.o)
         /usr/lib/libgaimisc.a(shr.o)
         /usr/lib/libgair4.a(shr.o)
         /usr/lib/libIM.a(shr.o)
         /opt/freeware/lib/libpangoft2-1.0.a(libpangoft2-1.0.so.0)
         /opt/freeware/lib/libfreetype.a(libfreetype.so.6)
         /opt/freeware/lib/libpixman-1.a(libpixman-1.so.0)
         /opt/freeware/lib/libpng12.a(libpng12.so.0)
         /opt/freeware/lib/libz.a(libz.so.1)
         /opt/freeware/lib/libexpat.a(libexpat.so.1)
         /usr/lib/libcrypt.a(shr.o)
         /usr/lib/libpthreads.a(shr_comm.o)
         /usr/lib/libgaimisc.a(shr_64.o)
         /usr/lib/libgair4.a(shr_64.o)
         /usr/lib/libodm.a(shr.o)
         /usr/lib/libodm.a(shr_64.o)

一切正常,启动之,OK,可以顺利启动了。

结果正常
附件: 您所在的用户组无法下载或查看附件
简单就是美!
我的Java:http://www.Java2Class.net

TOP